Having trouble?

Sorry to hear you are having trouble with our system.

Our system is compatible browsers such as Internet Explorer 11 on Windows 8.1 and the latest version of both Chrome and Firefox. Some people experience errors when they are using an older version of a browser.

We recommend two options: 

1. Install the latest update for Internet Explorer 
2. Install another browser. We recommend the latest version of Chrome, which can be downloaded here 

If the issue still persists after updating Internet Explorer or downloading Chrome, please do not hesitate to contact support@plum.io.


Feedback and Knowledge Base